Packages of GFD Dennou Club Product for ubuntu

About

Dennou-Ruby Products Ubuntu packages.

Products

How to install

First: Registration repository.

$ sudo add-apt-repository ppa:gfd-dennou/ppa

Next: Update Repository

$ sudo apt-get update

If you want to all dennou-ruby packages, simply

$ sudo apt-get update  
$ sudo apt-get install gphys dcl-f90

$ sudo apt-get update  

Sorry, Because of lacl of Man power, We cannnot prepare the packages for enough. But many Packages are maintained with debian official repostory.

If You want to use Most recently Version of DCL. Please Build From Source For DCL,DCL-F90 DCL-C And Then

$ sudo apt-get install libgsl-dev libfftw3-dev libnetcdf-dev
$ sudo gem install gphys

Then you will be able to use the Dennou Ruby Products.

Packages for Ubuntu 14.04 , 15.10 , 16.04

The packages list is as follows.

list of packages for trusty(i386, amd64)

dcl
dcl-c
dcl-f90
gphys
ispack
numru-met
ruby-dcl
ruby-gpv

list of packages for wily(i386, amd64)

dcl
dcl-c
dcl-f90
gphys
gtool5
ispack
numru-met
ruby-dcl
ruby-gpv

list of packages for xenial(i386, amd64)

dcl
dcl-c
dcl-f90
ispack
numru-met
ruby-dcl
ruby-gpv