Home: dennou ruby home page
Japanese version is here

VTK-Ruby

- Patch for the Visualization Toolkit (VTK) to use from Ruby-



The newest version is vtk-5.0.4-ruby-090125.patch for Vtk-5.0.4
Source which has been adapted the patch is vtk-5.0.4-ruby-090125.tar.gz

What's VTK-Ruby

VTK-Ruby is a patch for The Visualization ToolKit (VTK) to use from Ruby.
VTK is an open source, freely available software system for 3D computer graphics, image processing, and visualization used by thousands of researchers and developers around the world. The VTK is provided by Kitware, Inc.

Screenshot

If you click the picture, you can see a larger picture.

Install

In order to install this, you need CMake.
On CMake, set "VTK_WRAP_RUBY" and "BUILD_SHARED_LIBS" to "ON". Depending on your environment, you may have to specify "RUBY_EXECUTABLE", "RUBY_INCLUDE_PATH" and "RUBY_LIBRARY".
If you compile this without Tk, see the thread of vtkusers ML.
If you compile this using "Visual Studio" on Windows, set "Build Type" of Visual Studio to "Relese".